Copie du wikimiroir

Ceci est un miroir du wiki de pascal.chat. La modification, l’historique et la connexion se trouvent là-bas.

Main menu/fr

Deutsch · English · Español · Français · Italiano · Magyar · Nederlands · Português · Shqip · Slovenčina · Suomi · Македонски · Русский · 中文(中国) · 中文(台灣) · 日本語

Le menu principal contient les entrées suivantes : Fichier Edition Cercher Voir Project Exécuter Composants Outils Configuration Fenêtres Aide

Comme d'habitude, les options peuvent êtres sélectionnées soit en cliquant directement dessus à l'aide du bouton gauche de la souris, soit en tapant au clavier :

Sous-menu Fichier

Sous-menu Edition

Sous-menu Chercher

'''

Sous-menu Voir

Il permet le contrôle de l'affichage de différentes fenêtres sur l'écran.

Sous-menu Projet

Sous-menu Exécuter

Une utilisation très importante de ce sous-menu est la possibilité d'activer une fenêtre de terminal dans le mode console du Pascal. Si vous développez une application Pascal en mode console (ie qui n'utilise pas d'interface graphique avec formulaires, boutons et boîtes) vous devriez cocher la case "Utiliser une application de démarrage". La première fois que vous l'activerez et essaierez de Compiler/Exécuter, vous rencontrerez probablement un message un peu brutal

text
"xterm: Can't execvp /usr/share/lazarus//tools/runwait.sh: Permission denied".

Si cela arrive, vous devrez changer les permissions dans le fichier approprié (par exemple en utilisant chmod +x nomfichier, ou en utilisant un utilitaire Windows pour changer les permissions) ; vous devrez faire cela en tant que root. Après, chaque fois que vous lancerez le programme, un fenêtre en mode console apparaîtra et tous votre texte d'entrées/sorties (readln, writeln etc.) apparaîtra à l'intérieur.

Après que votre programme est fini de s'exécuter, le message "Press enter" apparaît à l'écran. Ceci vous permet de lire toutes les sorties générées par votre programme ; après vous pouvez appuyer sur 'entrer' la fenêtre de la console se fermera.

Voir le tutoriel : programmation Pascal en Mode Console.

Ces trois dernières options vous permettent d'ouvrir (et de maintenir) un projet test. Utilisez Fichier -> Ouvrir pour ouvrir un fichier .lpr, appuyez sur Annuler sur la boîte de dialogue suivante pour ouvrir ce fichier comme un fichier "source normal".

Sous-menu Composants

Sous-menu Outils

Sous-menu Configuration

La plupart des ses paramètres son générés automatiquement et sont en lecture seule.

Sous-menu Fenêtres

Contient une liste des fichiers actuellement ouverts et des fenêtres disponibles comme Editeur de sources Lazarus, Inspecteur d'objets et Messages. Cliquer sur le nom d'une des fenêtres la placera au premier plan et lui donnera le focus.

Sous-menu Aide

Si vous placez le curseur de l'éditeur au dessus d'un mot clef de la FeePascal Components Library (FCL) ou de la RunTime Library (RTL), mais pas de la Lazarus Components Library (LCL) et appuyez sur <<F1>> vous serez emmené vers la définition appropriée sur le site Internet. CETTE SECTION EST TOUJOURS EN COURS D'ELABORATION

À terme, cela deviendra un service complet d'aide en ligne, avec des informations sur la syntaxe Pascal, l'utilisation de l'EDI, la modification ou la création de composants, et des astuces sur la façon d'exécuter certaines tâches. Cette partie de la section de la Documentation (celle que vous êtes en train de lire) représente le début de ce processus. Nous avons besoin des contributions de quiconque se sent capable d'en fournir : le Wiki est très facile à modifier.


From the Free Pascal wiki, page "Main menu/fr", as it stood on 2021-12-08 after a change by Trev, out of the wiki's dump of 2024-05-26. Copyright stays with the author who wrote it, according to the old wiki's Licensing page. If you have concerns about this material, message the admin.

Version 3, dernière modification par WikiArchive .